Red Lion Area School District - District Internet - FirstLight isn't accessible at the moment – Incident details

Schoology experiencing major outage

District Internet - FirstLight isn't accessible at the moment

Resolved
Major outage
Started over 1 year agoLasted 18 minutes
Updates
  • Resolved
    Resolved

    District Internet - FirstLight is now operational!

  • Investigating
    Investigating

    District Internet - FirstLight cannot be accessed at the moment.